Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Warning
titleImportant:
  • We plan to deprecate EasyApache 3 on December 31, 2018. To migrate to EasyApache 4, click the EasyApache 4 Migration Tool link at the top of the EasyApache 3 interface (WHM >> Home >> Software >> EasyApache 3).
  • You can only migrate a system that runs Tomcat in cPanel & WHM version 76 or above. For more information, read our Tomcat documentation.
  • This section of the interface only exists in cPanel & WHM version 60 or later. In cPanel & WHM version 70 and later, you cannot revert with the interface.
  • In cPanel & WHM versions 60 through 66, this section of the interface will not appear unless you select either the EDGE or CURRENT tier in WHM's Update Preferences interface (WHM >> Home >> Server Configuration >> Update Preferences). If you wish to migrate from EasyApache 3 to EasyApache 4 and you select either the RELEASE or STABLE tiers, you must use the  /usr/local/cpanel/scripts/migrate_ea3_to_ea4 script.

...

  1. Navigate to the EasyApache 4  interface (WHM >> Home >> Software >> EasyApache 4).
  2. Click Migrate. A confirmation message will appear.
  3. To confirm that you wish to migrate, click Yes, run EasyApache 4 Migration. The system will start the EasyApache 4 migration and display the progress log. For more information about the migration process, read our The EasyApache 3 to EasyApache 4 Migration Process documentation.
  4. Click Done. You can also download the progress log for your records.
Note
titleNoteNotes:
  • If your system runs CloudLinux™ and you experience difficulty with the conversion, you may need to run the CloudLinux conversion script to migrate your system. 
  • If your system runs Tomcat, you must use cPanel & WHM version 76 or higher to migrate to EasyApache 4.

Servers that run cPanel & WHM versions 52 to 58

...

  1. Log in to your server via SSH.
  2. Run the following command as the root user:

    Code Block
    languagebash
    /usr/local/cpanel/scripts/migrate_ea3_to_ea4 --run


    Note
    titleNotes:
    • If your system runs CloudLinux™, the migrate_ea3_to_ea4 script downloads and runs CloudLinux's EasyApache 4 migration script.
    • If your system runs CloudLinux, you cannot use options (for example, the --install_profile optionprofile option) with the EasyApache 4 migration script.
    • As the migration script runs, the /scripts/migrate_ea3_to_ea4 script copies the /usr/local/lib/php.ini file to the /opt/cpanel/ea-php??/root/etc/php.d/php.ini file and to all installed ea-php versions on your server. To prevent complications, the system comments out lines that resemble the following lines:
      • extension=
      • extension_dir=
      • zend_extension-
    • The system does not adjust any other lines.


  3. The system displays the changes that will occur. To continue, follow the system's instructions. 

...

ArgumentDescription
--run

Run the script.

Warning
titleImportant:

You must include the --run option.


--helpDisplay the help information.
--revertRevert the system to the previous version and configuration.
--skip_convertDo not convert and install the EasyApache 3 profile. This flag installs the EasyApache 4 cPanel Default Profile unless you use the --install_profile flag.
--install_profile

Do not convert the EasyApache 3 profile. Instead, install the specified profile.

Code Block
languagebash
 /scripts/migrate_ea3_to_ea4 --run --install_profile /path/to/profile


--convert_fail

When you convert an EasyApache 3 profile to an EasyApache 4 profile, this flag prevents execution of the script's error-correction code.

Warning
titleWarning:

This may cause a failure when you provision your system. However, you may wish to use this flag for tests.


--allow-unsafe-amount-of-tomcat-users

Migrate a system that possesses more than five Tomcat users.

Note
titleNotes:
  • This flag only exists on systems that run cPanel & WHM version 76 or higher.
  • Tomcat consumes a high amount of memory. Make certain that your system possesses enough memory before you perform this action.


-y | --y | -yes | --yes

Answer yes to all of the script's yes-or-no questions.
--force

When you add the --force argument to the --run or --revert arguments, the system ignores the protection checks.

Warning
titleWarning:

 This may cause a failure when you provision your system.


--reinstallYum attempts to install the required EasyApache 4 RPMs and attempts to reinstall any currently-installed EasyApache 4 packages.

...